Pimax 8KX does not ...
Clear all

[Solved] Pimax 8KX does not work with 7900XTX

6 Posts
4 Users
Posts: 1
New Member Customer
Topic starter

Hi, Pimax 8KX is not working with 7900XTX any news about that?

Is Pimax working on that issue?

thanks for any info

This topic was modified 1 month ago by chinahasbeengenerous
Posted : 09/02/2023 6:02 am
Topic Tags
Posts: 128
Member Moderator

Hi @sebastian-hentzschel,

We formally discussed this issue with AMD and according to the information given by AMD technicians, the AMD 7900XTX GPU is not compatible with some headsets very well. Our team is trying hard to troubleshoot with AMD, but it's obvious that this will take some time.

This is now a known issue in AMD's Software release announcement. Frankly speaking, we are not sure when the problem will be solved. It would be much helpful if the users can report the issue to AMD as well. 


Posted : 09/02/2023 10:43 am
Posts: 2
New Member Customer


theres also problem with 5K plus. 

hope there will come a fix at some point 🙂


Posted : 08/03/2023 2:06 pm
Posts: 2
New Member Customer

It seems that the Pimax 8KX and 7900XTX compliance has not been confirmed. Pimax is working on defining this problem, but there is no concrete information about when it will be fixed yet. However, there are a few things you can try to improve the compatibility of your graphics card with the Pimax 8KX. You can update your graphics card drivers, install a newer version of the Pimax software, and check to see if your DisplayPort cable is plugged into the correct port on your graphics card.

Posted : 14/03/2023 10:39 pm
Posts: 2
New Member Customer

Thank you for publishing the text

This post was modified 1 week ago 2 times by BriaTyler
Posted : 15/03/2023 10:15 pm
Posts: 2
New Member Customer

I have been trying every driver since launch to see if it works.

I have the newest version of pimax store, but have also tried standalone pitool.

I have tried every displayport on gpu (even got a usb-c to displayport)

I have reinstalled everything (even windows)

I tried to disable the onboard gpu (ryzen 7 7700x)


Heres my observations:

with the latest driver installed you can still instant crash the gpu driver by changing the refresh rate away from 90hz in "pitool".

when you launch steamvr you just get black screen. if you disable basestation tracking and use the gyro you get image but returns to black screen if you go back to basestation tracking.

With the same system and driver I have been using a radeon 6650xt (my spare card) and that works.


It could be nice with some updates if theres any timeline or anything.

theres also a long post on it on openmr forum.

I have also sendt a bug report to AMD. 🙂

I hope its get compatible soon. 🙂

Posted : 16/03/2023 4:23 pm